当网站通过 HTTPS CDN 加载,但服务器或反向代理让程序识别为 HTTP 时,后台可能会生成 HTTP 接口地址。浏览器访问 HTTPS 页面时请求 HTTP 接口,可能会因混合内容策略被拦截。## 方法一:修改 .env在项目根目录的 .env 文件中设置:[BADOUADMIN]APP_URL = https://www.example.com将域名替换为网...
近期有用户反映,BadouCMS 2.1的版本升级到最新版本会出现method not exist:think\\db\\Query->clearCache的报错。> 这是因为在 BadouCMS 2.2的版本升级了 Thinkphp的 ORM导致的。出现这个错误请按照下面的方法进行修改1、先升级框架程序...
为什么后台的内容管理无法打开> 因为有些版本的测试数据有问题,所以有时候会导致菜单变成菜单目录,下面说一下这个问题应该如何解决如果安装CMS插件之后出现“内容管理”菜单无法打开的情况,请打开权限管理 > `...
上传(文件类型及大小)修改在BadouCMS中如何修改文件的类型以及上传的文件的大小呢?其实很简单,打开项目文件,找到config文件夹。::: info打开文件:config/upload.php:::修改如下配置文件即可`phpreturn [/ 上传地址,默认是本地上传 /'uploadurl' => 'ajax/upload',/ CDN地址 /...
重置密码脚本,用完必须删除使用说明:将脚本放到public目录后,将文件名字改成resetpwd.php访问此脚本:你的域名/resetpwd.php输入要重置的管理员用户名和新密码重置成功后,请立即删除此文件(必须删除,否则有安全隐患!!!)安全提示:自动从.env读取数据库配置,如果没有,请将.env.example文件...
一、问题背景本地搭建Windows宝塔环境(采用nginx+PHP8.2+MYSQL5.7,Linux宝塔环境可忽略),在使用PbootCMS数据迁移插件时,出现 “Class 'ZipArchive' not found” 报错。经检测,核心原因是PHP的zip拓展未安装/启用。## 二、关键说明与Linux宝塔不同,Windows宝塔面板的拓展列表中通常没有独立的ZIP拓展安...
我们在操作pbootcms一键转换badoucms的时候,经常会碰到一个问题,就是Pbootcms的自定义模型,在badoucms后台怎么实现同步到内容管理里面呢?明明数据已经同步了,前端页面也同步展示了,为什么后台没有自定义模型的内容管理呢?
问题现状:有10个站点,仅有一个站点A开启了SSL(https),通过https访问B/C/D等站点时,页面竟然是A站点。
badoucms在服务器环境Nginx,Apache,IIS下可以通过 URL 重写隐藏应用的入口文件 index.php, 具体方法参考本文内容
DNMP 是基于 Docker 的 PHP 开发环境,集成了 Nginx、MySQL、Redis、PHP 多版本等,适合本地开发和测试。
在使用Badoucms时,如果上传出现如图的错误,一般是缺少PHP扩展导致的Upload failed, please try again.status: 500 - Internal Server Erro
Nginx,Aphace禁止访问某个目录或某个后缀文件(如php、zip)
BadouCMS